You are here:
< Back

Rekord Buddy 2.0 requires macOS 10.9 or above. A version supporting 10,8 is still in the works but there is no guarantee this will be doable.

If you want more info about the 10.8 version, please email support@next.audio.

Close
Go top